PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN

  • Overview
  • Comparing elements
  • Comparing the current element with another element
  • Comparing two elements
  • Comparing two projects
  • Differences found between two elements or two projects
  • Carrying over the differences from an element to another one
  • Limitations
  • Comparing two analyses
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReports and QueriesUser code (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Browser code
WINDEV Mobile
AndroidAndroid Widget iPhone/iPadIOS WidgetApple WatchMac CatalystUniversal Windows 10 App
Others
Stored procedures
Overview
Comparing two windows (two pages, two reports, two classes, ...) is a common need in the life of an application.
For example, a window that used to operate properly two weeks ago was modified by a trainee. This window does not operate anymore. Is it possible to find out the modifications made to this window? All you have to do is used the project comparator!
The project comparator is used to compare two projects or two elements (windows, pages, reports, ...) between themselves.
The comparison is performed:
  • on the UI of the element and sub-elements (a window and the controls found in this window for example).
    Remark: If the window contains layouts, the comparison is performed on each layout.
  • on the code associated with the element and sub-elements (a report and the controls found in this report for example).
All the differences found between the two elements are listed.
The following elements can be compared:
  • Projects.
  • All objects of the project.
  • Windows or window templates.
  • Pages.
  • Reports.
  • Queries.
  • Analyses.
  • Classes.
  • Sets of procedures.
  • Analyses.
  • Style sheets.
  • Automated tests.
  • Descriptions of REST Webservice.
  • Action plans.
  • Internal components.
Remark: When comparing projects, the following elements are also compared:
  • Stored procedures.
  • Stored queries.
  • Triggers.
  • Properties of project (version numbers, copyright information, etc.).
  • Images.
Comparing elements
The element comparator is used to compare:
  • the current element with another element.
  • two elements.
  • three elements.
  • two projects.

Comparing the current element with another element

To compare the current element with another element:
  1. On the "Project" tab, in the "Other actions" group, expand "Compare" and select "Compare current element". The comparison wizard starts.
  2. Select the element that must be compared with the current element.
  3. Validate. All the differences found between the two elements are listed.

Comparing two elements

To compare two elements:
  1. On the "Project" tab, in the "Other actions" group, expand "Compare" and select "Compare 2 elements". The comparison wizard starts.
  2. Select the type of element to compare (project, window, page, report, ...).
  3. Select the two elements to compare.
  4. Validate. All the differences found between the two elements are listed.

Comparing two projects

To compare two projects:
  1. On the "Project" tab, in the "Other actions" group, expand "Compare" and select "Compare two projects". The comparison wizard starts.
  2. Select the two projects that must be compared.
  3. Validate. All the differences found between the two projects are listed.
Differences found between two elements or two projects
The differences are listed according to the following order:
  • Code difference: is used to simultaneously see the code of the two elements currently compared.
  • Difference of properties: is used to see the different characteristics.

Carrying over the differences from an element to another one

The differences can be carried over from an element to another one.
For more details, see Carrying over the differences.
Limitations

Comparing two analyses

When comparing two analyses, the following characteristics are ignored:
  • the dimensions and the position of the different graphic objects representing the analysis.
  • the shared information.
  • the options in the "Options" tab of the analysis description window.
Minimum version required
  • Version 9
This page is also available for…
Comments
Click [Add] to post a comment