PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Overview
  • WDLog
  • Use
  • Starting WDLog
  • Use conditions
  • Reminder: Data file log
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReports and QueriesUser code (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Browser code
WINDEV Mobile
AndroidAndroid Widget iPhone/iPadIOS WidgetApple WatchMac CatalystUniversal Windows 10 App
Others
Stored procedures
Overview

WDLog

The different operations that can be performed by WDLog are as follows:
Remark: When modifying the analysis, the log file will be automatically saved during the automatic modification of the data files. The log file will be cleared later.
Use

Starting WDLog

To start WDLog:
  • In interactive mode:
    • from WINDEV, WEBDEV or WINDEV Mobile: on the "Tools" tab, in the "Utilities" group, click "WDTool" and select "WDTool".
    • run the "WDLOG.EXE" program found in the "Programs" sub-directory of setup directory of WINDEV, WEBDEV and WINDEV Mobile.
  • From a command line.
In interactive mode, the different options of the drop-down menu allow you to access all the features of WDLog.

Use conditions

WDLog can be redistributed. WDLog can be installed with the applications developed with WINDEV and/or WEBDEV. The license agreement of WINDEV, WEBDEV or WINDEV Mobile is fully enforced.
WDLog can be included in your applications when creating the setup procedure.
Reminder: The setup procedure can be created:
  • from the wizard. To start the wizard, go to the "Project" tab, "Generation" group, expand "Setup procedure" and select "Create setup procedure".
  • from the setup editor. To start the setup editor, go to the "Tools" tab, "Utilities" group and click "WDInst".
The following files are required to install WDLog:
  • WDLog.EXE
  • wdxxxcom.dll
  • wdxxxetat.dll
  • wdxxxgrf.dll
  • wdxxxhf.dll
  • wdxxxmat.dll
  • wdxxxobj.dll
  • wdxxxpnt.dll
  • wdxxxstd.dll
  • wdxxxsql.dll
  • wdxxxvm.dll
  • wdxxxzip.dll
  • WDOutil.WDK
  • WDJournal.CHM
  • WDLog.CHM
Reminder: Data file log
WINDEV, WEBDEV and WINDEV Mobile allow you to create a log file for each data file. This log file can be:
  • A file of write operations
  • A file of read/write operations
The log contains the history of the logged files:
  • The values of the record items before the data file was modified,
  • The values of the record items once the data file was modified,
  • The author of the operation,
  • The date of the operation,
  • The computer where the operation was performed,
  • A comment,
  • The IP address of the computer where the operation was performed,
  • The application name,
  • The network name of the user,
  • The nature of the operation (add, modify, delete, read, ...).
The data files are logged in the data model editor of WINDEV, WEBDEV or WINDEV Mobile.
Minimum version required
  • Version 9
This page is also available for…
Comments
Click [Add] to post a comment