PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Possible error cases:
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReports and QueriesUser code (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Browser code
WINDEV Mobile
AndroidAndroid Widget iPhone/iPadIOS WidgetApple WatchMac CatalystUniversal Windows 10 App
Others
Stored procedures
<sfConnection variable>.ForwardQuery (Function)
In french: <Variable sfConnexion>.AvanceRequête
Continues to run a SOQL query (Salesforce Object Query Language) on the records of a Salesforce database. The query was run by SFExecuteQuery.
Versions 20 and later
WINDEVLinux This function is now available for WINDEV applications in Linux.
New in version 20
WINDEVLinux This function is now available for WINDEV applications in Linux.
WINDEVLinux This function is now available for WINDEV applications in Linux.
Versions 24 and later
Linux This function is now available for WEBDEV sites in Linux.
New in version 24
Linux This function is now available for WEBDEV sites in Linux.
Linux This function is now available for WEBDEV sites in Linux.
Example
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx.Login = "balthazar@gmail.com"
Cnx.MotDePasse = "azerty" + "XXB12VCZ54"
SI Cnx.Connecte() = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
 
ResRequête est un sfRésultatExécuteRequête
ResRequête = Cnx.ExécuteRequête("SELECT Date__c,Miles__c,Contact__c FROM Mileage__c")
 
BOUCLE
MonEnregistrement est un sfObjet
POUR TOUT MonEnregistrement DE ResRequête..Objet
Trace("---- Type: " + MonEnregistrement..TypeObjet + " | ID: " + MonEnregistrement..ID)
Trace(MonEnregistrement..Date__c + " / " + ...
MonEnregistrement..Miles__c + " / " + MonEnregistrement..Contact__c)
FIN
ResRequête = Cnx.AvanceRequête(ResRequête..LocalisationRequête)
À FAIRE TANTQUE PAS ResRequête..Fini
 
POUR TOUT MonEnregistrement DE ResRequête..Objet
Trace("---- Type: " + MonEnregistrement..TypeObjet + ...
" | ID: " + MonEnregistrement..ID)
Trace(MonEnregistrement..Date__c + " / " + ...
MonEnregistrement..Miles__c + " / " + MonEnregistrement..Contact__c)
FIN
Syntax
<Result> = <Salesforce connection>.ForwardQuery(<Query location>)
<Result>: sfExecuteQueryResult variable
Name of sfExecuteQueryResult variable that contains the result data, especially the Salesforce records corresponding to the query result.
<Salesforce connection>: sfConnection variable
Name of the Variable type sfConnection to be used.
<Query location>: Unicode string
String used to identify the query. This string is obtained thanks to the Property LocationRequest of the last received Variable sfExecuteQueryResult.
Remarks

Possible error cases:

  • The Internet connection is not valid.
  • The authentication was not performed properly.
  • The XML response of the server cannot be read.
To find out whether an error occurred, use the ErrorOccurred variable.
Component: wd270ggl.dll
Minimum version required
  • Version 24
This page is also available for…
Comments
Click [Add] to post a comment