PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Use conditions
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReports and QueriesUser code (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Browser code
WINDEV Mobile
AndroidAndroid Widget iPhone/iPadIOS WidgetApple WatchMac CatalystUniversal Windows 10 App
Others
Stored procedures
On a given row of a Looper control:
  • collapses a break (if it is expanded),
  • expands a break (if it is collapsed).
Example
// Expands on user click
LooperCollapseExpand(LOOP_Products)
Syntax
<Result> = LooperCollapseExpand(<Looper control> [, <Row number> [, <Break name>]])
<Result>: Integer constant
Versions 25 and later
State of the row before LooperCollapseExpand is called:
taExpandExpanded row.
taCollapseCollapsed row.
taErrorNo row found.
New in version 25
State of the row before LooperCollapseExpand is called:
taExpandExpanded row.
taCollapseCollapsed row.
taErrorNo row found.
State of the row before LooperCollapseExpand is called:
taExpandExpanded row.
taCollapseCollapsed row.
taErrorNo row found.
<Looper control>: Control name
Name of the Looper control to be used.
If this parameter is equal to an empty string (""), the current Looper control is used.
<Row number>: Optional integer
Number of the row to collapse or expand.
If this parameter is not specified, the current row is used.
<Break name>: Optional character string
Name of the break to modify. This parameter must be specified in case of nested breaks. It is used to define the break that will be handled. By default, no break is expanded or collapsed if the breaks are nested.
Remarks

Use conditions

LooperCollapseExpand can be used on a browsing or memory Looper control.
WEBDEV - Browser code This function is not available for Linear Looper controls. This function is available for Looper controls in browser mode only.
WEBDEV - Server codePHP This function is available for Looper controls in Ajax mode, Looper controls in classic mode and Linear Looper controls.
Business / UI classification: UI Code
Component: wd270obj.dll
Minimum version required
  • Version 17
This page is also available for…
Comments
Click [Add] to post a comment