PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Propriétés spécifiques à la description des variables de type tblrSélection
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Le type tblrSélection permet de connaître toutes les caractéristiques avancées d'une sélection dans un champ Tableur. Les caractéristiques de cette sélection peuvent être connues à l'aide de différentes propriétés WLangage.
La propriété .Sélection permet d'obtenir une variable de type tblrSélection.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
sel est un tblrSélection = TBLR_MonTableur.Sélection
SI sel.Type = tblrSelSimpleCell ALORS
// Afficher le nom de la cellule dans la barre de message
MGSBAR = sel.CelluleMin
FIN
t est un tblrSélection
t = TBLR_SansNom1.Sélection
SELON t.Type
CAS tblrSelSimpleCell : Trace("Vous avez sélectionné une seule case.")
CAS tblrSelSimpleEntête : Trace("Vous avez sélectionné un seul entête.")
CAS tblrSelMultiCell : Trace("Vous avez sélectionné plusieurs cases.")
CAS tblrSelMultiEntête : Trace("Vous avez sélectionné plusieurs entêtes.")
CAS tblrSelRectCell : Trace("Vous avez sélectionné plusieurs cases (rectangle).")
CAS tblrSelVide : Trace("Vous n'avez sélectionné aucune case.")
CAS tblrSelTout : Trace("Vous avez sélectionné toute la feuille.")
AUTRE CAS
FIN
 
te est un tableau de chaînes = t.Entête
tc est un tableau de chaînes = t.Cellule
Trc est un tableau de chaînes = t.RectCellule
Trace("-----------------------------")
Trace("")
 
Trace("Cellule min:", t.CelluleMin)
Trace("Cellule max:", t.CelluleMax)
Trace("-----------------------------")
Trace("")
 
Trace("Parcours des entêtes")
POUR i = 1 À te.Occurrence
Trace("entête " + i + ":", te[i])
FIN
Trace("-----------------------------")
Trace("")
 
Trace("Parcours des cellules")
POUR i = 1 À tc.Occurrence
Trace("cellule " + i + ":", tc[i])
FIN
Trace("-----------------------------")
Trace("")
 
Trace("Parcours d'un rectangle de cellules")
POUR i = 1 À Trc.Occurrence
Trace("rect cellule " + i + ":", Trc[i])
FIN
Trace("-----------------------------")
Trace("")
Remarques

Propriétés spécifiques à la description des variables de type tblrSélection

Les propriétés suivantes peuvent être utilisées pour manipuler une sélection dans un champ Tableur :
Nom de la propriétéType manipuléEffet
CelluleTableau de chaînesTableau des cellules sélectionnées. Les cellules dans le tableau sont triées selon l'ordre de sélection.
Cette propriété est disponible en lecture seulement.
CelluleMaxChaîne de caractèresCellule maximale sélectionnée, c'est-à-dire la cellule en bas à droite du rectangle délimitant la sélection des cellules.
Cette propriété est disponible en lecture seulement.
CelluleMinChaîne de caractèresCellule minimale sélectionnée, c'est-à-dire la cellule en haut à gauche du rectangle délimitant la sélection des cellules.
Cette propriété est disponible en lecture seulement.
EntêteTableau de chaînesEntêtes sélectionnés (entêtes de lignes et/ou colonnes sélectionnées).
Cette propriété est disponible en lecture seulement.
RectCelluleTableau de chaînesTableau des rectangles des cellules sélectionnées. Exemple : "A1:B2"
Cette propriété est disponible en lecture seulement.
TypeConstante de type EntierType de sélection :
  • tblrSelMultiCell : Plusieurs cases sont sélectionnées.
  • tblrSelMultiEntête : Plusieurs entêtes sont sélectionnés.
  • tblrSelRectCell : Plusieurs cases sont sélectionnées et elles forment un rectangle.
  • tblrSelSimpleCell : Une seule case est sélectionnée.
  • tblrSelSimpleEntête : Un seul entête est sélectionné.
  • tblrSelTout : Toute la feuille est sélectionnée.
  • tblrSelVide : Aucune sélection.
Cette propriété est disponible en lecture seulement.
Minimum version required
  • Version 23
Comments
Click [Add] to post a comment