PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReports and QueriesUser code (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Browser code
WINDEV Mobile
AndroidAndroid Widget iPhone/iPadIOS WidgetApple WatchMac CatalystUniversal Windows 10 App
Others
Stored procedures
Finds a character string in an entire Word Processing control.
Example
tabFragments est tableau de docFragments = TT_MonDocument.Recherche("%NomClient%")
// Remplacement de tous les "%NomClient%" par le nom du client
POUR TOUT f DE tabFragments
f.Texte = Client.Nom
FIN
// Recherche du mot "BEAUGRAND" dans le texte
// Sélectionne uniquement le premier trouvé pour changer sa couleur
tabFragments est tableau de docFragments = TT_SansNom1.Recherche("BEAUGRAND")
 
SI tabFragments.Occurrence >= 1 ALORS
// Positionnement du curseur au début du premier mot trouvé
TT_SansNom1.Curseur = tabFragments[1].PositionDébut
// Calcul de la longueur de la sélection
TT_SansNom1.LongueurSélection = ...
tabFragments[1].PositionFin - tabFragments[1].PositionDébut+1
// Modification de la couleur du texte
tabFragments[1].MiseEnForme.CouleurTexte = RougePastel
SORTIR
FIN
Syntax
<Result> = <Word Processing control>.Search(<Text to find> [, <Options>])
<Result>: Array of docFragment variables
Array of docFragment variables corresponding to all the document fragments where the searched text was found.
<Word Processing control>: Control name
Name of the Word Processing control to use.
<Text to find>: Character string
Text to find in the control.
<Options>: Optional constant (or combination of constants)
Search options:
WholeWordSearch for the whole word (enclosed in punctuation characters or in space characters).
IgnoreCaseCase and accent insensitive search (ignores uppercase and lowercase differences).

By default, the search is case-sensitive: the searched text and the text to find must have the same case. To perform a case-insensitive search, use the IgnoreCase constant.
Business / UI classification: UI Code
Component: wd270mdl.dll
Minimum version required
  • Version 23
This page is also available for…
Comments
Click [Add] to post a comment