PC SOFT

ONLINE HELP
FOR WINDEV, WEBDEV AND WINDEV MOBILE

Home | Sign in | English US
  • Overview
  • Displaying and modifying the description of a report
  • Overview
  • Managing the data source
  • Display options in the print preview
  • Managing blocks
  • Format
  • Options
  • Form and background image
  • Language
  • Opening, closing and saving a report
  • Opening a report
  • Closing a report
  • Saving a report
  • Automatic retrieval
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReports and QueriesUser code (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Browser code
WINDEV Mobile
AndroidAndroid Widget iPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Others
Stored procedures
Handling a report (in the editor)
Overview
Once a report was created, the description of this report can be modified at any time:
  • data source,
  • controls found in the report,
  • layout, ...
Only the report type cannot be modified. Indeed, too many specific parameters are involved. To change the report type, all you have to do is create a new report.
This help page presents:
Displaying and modifying the description of a report

Overview

The main options of the report can be accessed in the report description ("Report description" from the popup menu). See the context-sensitive help of description window for more details ( Context-sensitive help ).
Let's take a quick look at the different tabs of report description.
Note: The main options of report can also be accessed via the "Modifier" pane.

Managing the data source

The data source of a report can be configured and modified at any time. In most cases, these operations are performed from the description window of the report.
You have the ability to:
  • modify the data source of report ("Data" tab of report description):
    • by changing the type of the data source for the report (switching from a report based on a query to a report based on a data file or on a memory zone for example).
    • by changing the parameters of the selected data source (modify the query or the sort, implement bounds, ...).
  • configure the operating mode of report if the data source is empty ("Details" tab of report description). If the data source is empty, the report editor gives you the ability to print the report or to display a warning message without printing the report. The warning message can be configured.configure the operating mode of report if the data source is empty ("GUI" tab of report description). If the data source is empty, the report editor gives you the ability to print the report or to display a warning message without printing the report. The warning message can be configured.
Note: If the report is based on a query, select "Edit the query" from the popup menu to directly edit the query in the query editor. Then, this query can be modified.

Display options in the print preview

The display options for the print preview are configured in the "Details" tab of report description. You have the ability to:
  • specify the export formats proposed by the print preview. The selected formats will be available for the user.
  • configure the message displayed if the data source is empty.
  • specify whether the report can be modified in "Reports and Queries" and under which conditions. See Reports & Queries for more details.
  • specify whether the compiled code must be included. This option is required in very rare cases only.
  • specify whether the space characters that fill the items must be taken into account. This option only applies to auto-sizable controls associated with a text item filled with spaces.
  • specify whether the print must be performed page by page. In this case, the print is sent to the print spooler after each printed page.
  • specify whether the first page is a cover page. In this case, the first page will be displayed on the right in the preview (in side-by-side display mode).
The configuration of display options in the print preview is performed in the "GUI" tab of report description. You have the ability to:
  • specify the export formats proposed by the print preview. The selected formats will be available for the user.
  • configure the message displayed if the data source is empty.
  • Versions 19 and later
    configure the message displayed while selecting and sorting records.
    New in version 19
    configure the message displayed while selecting and sorting records.
    configure the message displayed while selecting and sorting records.

Managing blocks

The report blocks can be managed in the report currently edited or in the description window of report.
The blocks can be managed:
  • from the options found in the popup menu of blocks (right mouse click on the caption of blocks).
  • via the description window of the report ("Report description" from the popup menu), "Blocks" tab.
See Report blocks for more details.

Format

The "Format" tab of the description window of report is used to configure:
  • the page format (or the format of label sheet).
  • the indent of controls (in order for the control text not to be stuck to the control border).
  • the margins.
  • the page orientation (portrait or landscape).
  • the format of labels if the report is a label report.
  • Versions 15 and later
    the number of columns.
    You also have the ability to create multi-column reports.
    New in version 15
    the number of columns.
    You also have the ability to create multi-column reports.
    the number of columns.
    You also have the ability to create multi-column reports.
  • Versions 19 and later
    the number of pages in width. In this case, a large report (whose size exceeds the size of a paper sheet) will be printed on several pages. The end user will only have to assemble the pages. See Multi-page print for more details.
    New in version 19
    the number of pages in width. In this case, a large report (whose size exceeds the size of a paper sheet) will be printed on several pages. The end user will only have to assemble the pages. See Multi-page print for more details.
    the number of pages in width. In this case, a large report (whose size exceeds the size of a paper sheet) will be printed on several pages. The end user will only have to assemble the pages. See Multi-page print for more details.

Options

The "Options" tab found in the description window of report is used to configure:
  • the operating mode of report if the page format is not supported by the printer.
  • the position of blocks when printing the report.
  • the table style if the report contains a table.
  • the list of templates used by the report.
  • the style of labels if the report is a label report.
This tab is also used to:
  • configure the report for using Reports and Queries. See Reports & Queries for more details.
  • specify whether the compiled code must be included. This option is required in very rare cases only.
  • configure some specific parameters:
    • Whether the pages must be sent one by one to the print spooler (print performed page after page). In this case, the print is sent to the print spooler after each printed page.
    • Whether the space characters that fill the items must be taken into account. This option affects the self-expanding controls associated with a text item filled with space characters (backward compatibility with WINDEV 5.5).
    • Whether the first page is a cover page. In this case, the first page will be displayed on the right in the preview (in side-by-side display mode).
    • Versions 22 and later
      Whether the code of cloned controls must be run. This option is checked by default. If this option is unchecked, the report behavior will correspond to the one of versions 21 and earlier: the code of cloned controls will not be run.
      New in version 22
      Whether the code of cloned controls must be run. This option is checked by default. If this option is unchecked, the report behavior will correspond to the one of versions 21 and earlier: the code of cloned controls will not be run.
      Whether the code of cloned controls must be run. This option is checked by default. If this option is unchecked, the report behavior will correspond to the one of versions 21 and earlier: the code of cloned controls will not be run.
    • Versions 23 and later
      Overload the programming standard defined at project level (via the "Programming standard" button). See Project description: Compilation tab for more details.
      New in version 23
      Overload the programming standard defined at project level (via the "Programming standard" button). See Project description: Compilation tab for more details.
      Overload the programming standard defined at project level (via the "Programming standard" button). See Project description: Compilation tab for more details.

Form and background image

Most types of reports can be created from a form. The "Background" tab allows you to define the image used as form in the report. This image can be printed (or not) with the report.
This option is very useful for the reports that must be printed on a pre-printed form. The form is included in the report, allowing you to easily position the records to print. Printing has now become hassle-free.
See Report on form for more details.

Language

A report can be multilingual: this report can be displayed and printed in several languages.
The "Language" tab is used to configure:
  • the languages supported by the current report.
  • the language displayed in the report editor: this language will be used by default when the report is displayed in the editor.
The following information can be entered in several languages:
  • all the messages displayed while the report is printed. These messages are translated in the different description windows.
  • the caption of Static controls or RTF controls: To translate these captions, all you have to do is modify the language displayed in the report ("Display .. Language displayed") and enter the translations in the report in edit.To translate these captions, you must:
    • modify the language displayed in the report: on the "Display" pane, in the "Options" group, expand "Language displayed" and select the requested language.
    • enter the translations in the report in edit.
  • the input mask of item controls, calculated controls or preset controls.
  • the image files used in the report.
  • the form of the report.
Opening, closing and saving a report

Opening a report

To open a report, you have the ability to use one of the following methods:
  • select "File .. Open".on the "Home" pane, in the "General" group, expand "Open" and select "Open". Then, select the "WDE" file to open.
  • click Open and select "Open". Then, select the "WDE" file to open. click Open among the quick access buttons and select "Open". Then, select the "WDE" file to open.
  • double-click a "WDE" file directly.
  • double-click the name of a report in the "Project explorer" pane.

Closing a report

To close the current report, use one of the following methods:
  • click the cross found in the top right corner of the title bar of the report currently edited.
  • select "File .. Close". on the "Home" pane, in the "General" group, expand "Close" and select "Close".
If the report contains unsaved modifications, the report editor automatically proposes to save the report.

Saving a report

To save the current report, use one of the following methods:
  • select "File .. Save".on the "Home" pane, in the "General" group, click Save.
  • press CTRL + S.
  • click Save among the quick access buttons.
Note: To save the report under a different name, select "File .. Save as".Note: To save a report while renaming it, on the "Home" pane, in the "General" group, expand "Save" and select "Save as".

Automatic retrieval

To avoid problems when a system lock occurs (power outage for example), WINDEV, WEBDEV and WINDEV Mobile propose a system used to automatically retrieve the elements opened in the different editors
When this system is enabled:
  • an automatic backup of the opened elements is regularly performed at specific time intervals (every 10 minutes by default).
  • when a report is re-opened after a system lock, a window for automatic retrieval is displayed. This window proposes to retrieve:
    • the report as it was during the last backup performed from the report editor.
    • the report automatically saved.
      The selected version is automatically opened in the editor. The non-selected version is available in the window for managing the versions and it can be opened at any time. See the managing the versions for more details.
To enable the system for automatic retrieval:
  1. Select "Tools .. Options .. General options of xxx".On the "Home" pane, in the "Environment" group, expand "Options" and select "General options of xxx".
  2. Display the "General" tab and check "Backup for automatic retrieval'.
  3. Specify the time-out for the automatic backup.
  4. Validate.
To retrieve a version in the window for version management:
  1. Select "File .. Versions".On the "Home" pane, in the "General" group, expand "Save" and select "Versions".
  2. Select the version to retrieve.
  3. Validate.
See also
Minimum required version
  • Version 10
This page is also available for…
Comments
Click [Add] to post a comment