PC SOFT

WINDEVWEBDEV AND WINDEV MOBILE
ONLINE HELP

Home | Sign in | English UK

  • Overview
  • Project tab
  • Miscellaneous
  • Spelling checker
  • Synchronizing the templates
  • Generating the pages
  • Development in strict mode
  • Programming charter
  • Code style
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReports and QueriesUser code (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Browser code
WINDEV Mobile
AndroidAndroid Widget iPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Others
Stored procedures
Overview
The description window of project is used to configure several elements of your project. This window includes the following tabs:
  • The "Project" tab that is used to enter the main project information
  • The "Analysis" tab that is used to associate an analysis with the project and/or with a UML model
  • The "Files" tab that is used to enter information about the data files managed by the application (only if the project is linked to an analysis).
  • The "Live data" tab that is used to configure the display of data (coming from the data files) in the different editors.
  • The "Languages" tab that is used to configure the different languages handled by the project as well as the linguistic options that will be used for each language.
  • The "Style" tab that is used to choose the theme of skin template and the custom style sheet, and to customize the print preview. You also have the ability to configure the size of screens.
  • The "Group" tab that is used to manage the teamwork (developer groupware or SCM).
  • The "Options" tab that is used to configure the options for updating, saving and synchronizing the templates. This tab is also used to enable the strict mode and to define the programming charter.The "Options" tab that is used to configure the options for updating, saving and synchronizing the templates. This tab is also used to enable the strict mode and to define the code style.
  • The "Advanced" tab that is used to manage the use of "Reports & Queries", the AAFs and the application lock.
  • The "Compilation" tab that is used to configure the compilation options.
  • Versions 22 and later
    The "Telemetry" tab that is used to configure the telemetry options for the project.
    WEBDEV - Server code This option is not available.
    New in version 22
    The "Telemetry" tab that is used to configure the telemetry options for the project.
    WEBDEV - Server code This option is not available.
    The "Telemetry" tab that is used to configure the telemetry options for the project.
    WEBDEV - Server code This option is not available.
Project tab

Miscellaneous

The following are diverse options:
  • "Ask for the location of the new elements in the project": If this option is selected, the location of a new element is automatically requested to save it in the project..
  • "Generate all the configurations in the "Exe" directory (not recommended if several configurations)": If this option is selected, all configurations will be generated in the same directory. If this option is not selected, each project configuration will be generated in a subdirectory of the project's 'Exe' directory. This generation subdirectory will have the same name as the project configuration subdirectory.
  • "Include the new elements only in the current configuration": If this option is selected, all new project elements will automatically be included only in the current project configuration in the editor.
Versions 24 and later
WINDEV

Spelling checker

This option allows you to:
  • Choose the spelling checker used. This spelling checker will be used by default to correct the spelling in edit controls and Word Processing controls.
  • "Automatically copy the dictionaries into the generation directory": If this option is selected, the dictionaries corresponding to the languages of the application will be automatically copied into the generation directory when the application is generated.
New in version 24
WINDEV

Spelling checker

This option allows you to:
  • Choose the spelling checker used. This spelling checker will be used by default to correct the spelling in edit controls and Word Processing controls.
  • "Automatically copy the dictionaries into the generation directory": If this option is selected, the dictionaries corresponding to the languages of the application will be automatically copied into the generation directory when the application is generated.
WINDEV

Spelling checker

This option allows you to:
  • Choose the spelling checker used. This spelling checker will be used by default to correct the spelling in edit controls and Word Processing controls.
  • "Automatically copy the dictionaries into the generation directory": If this option is selected, the dictionaries corresponding to the languages of the application will be automatically copied into the generation directory when the application is generated.

Synchronizing the templates

The option "Synchronize the templates during the generation" allows you to automate the synchronization of control, window, page or report templates when generating the application.
WEBDEV - Server code

Generating the pages

The option "Generate the HTML pages in the current language for the test mode" allows you to generate WEBDEV pages in HTML more quickly by taking into account only the current language during a test.

Development in strict mode

Strict mode development consists in using the tasks defined in the Project Monitoring Center for development.
If the option "Enable the strict mode" is selected, the developer will not be able to modify an element of the project without first selecting the task affected by these modifications.

Programming charter

A programming charter is used to automatically prefix the name of all the variables and the name of all the project elements (window, report control, class, ...). This automatic prefixing is used to easily identify and/or find an element of a given type.
To implement the programming charter in the project, simply select "Automatically prefix the variables and the elements found in the project". You can:
  • choose the desired programming charter.
    The buttons "Create a code style" and "Edit code style" make it possible to create and customize a programming charter.
  • automatically add (or not) the prefixes ("Add the prefixes automatically").
See Programming charter for more details.

Code style

A code style is used to automatically prefix the name of all the variables and project elements (windows, report controls, classes, etc.). This automatic prefixing allows you to easily identify and/or find an element of a given type.
To use the code style in the project, simply select "Automatically prefix the variables and the elements found in the project". You can:
  • choose the desired code style.
    The buttons "Create a code style" and "Edit code style" allow you to create and customize your own code style.
  • automatically add (or not) the prefixes ("Add the prefixes automatically").
See Code style for more details.
Minimum version required
  • Version 10
This page is also available for…
Comments
Click [Add] to post a comment